const regex = /[\'\"](.*)[\'\"]\s*=>\s*(.*),*\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\\'\\"](.*)[\\\'\\"]\\s*=>\\s*(.*),*\\s', 'gm')
const str = `'Default - Auto' => '',
'Cover' => 'cover',
'Contain' => 'contain', `;
const subst = `$2\t\t\t\t\t\t=> __('$1', 'default'),\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);