// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)[\'\"](.*)[\'\"]\s*=>\s*(.*),*\s"#).unwrap();
let string = "'Default - Auto' => '',
'Cover' => 'cover',
'Contain' => 'contain', ";
let substitution = "$2\\t\\t\\t\\t\\t\\t=> __('$1', 'default'),\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}