const regex = /(?<protocol>s?ftp):\/\/(?:(?<user>[^@\s]+)@)?(?<host>[^\?\s\:]+)(?:\:(?<port>[0-9]+))?(?:\?(?<password>.+))?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<protocol>s?ftp):\\\/\\\/(?:(?<user>[^@\\s]+)@)?(?<host>[^\\?\\s\\:]+)(?:\\:(?<port>[0-9]+))?(?:\\?(?<password>.+))?', 'g')
const str = `ftp://anonymous@example.net:21
ftp://wearenaive.net
ftp://127.0.0.1
sftp://authenticatedUser@securesite.com:558?password`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}