import re
regex = re.compile(r"(?<protocol>s?ftp):\/\/(?:(?<user>[^@\s]+)@)?(?<host>[^\?\s\:]+)(?:\:(?<port>[0-9]+))?(?:\?(?<password>.+))?")
test_str = ("ftp://anonymous@example.net:21\n"
"ftp://wearenaive.net\n"
"ftp://127.0.0.1\n"
"sftp://authenticatedUser@securesite.com:558?password")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")