use strict;
my $str = 'ftp://anonymous@example.net:21
ftp://wearenaive.net
ftp://127.0.0.1
sftp://authenticatedUser@securesite.com:558?password';
my $regex = qr/(?<protocol>s?ftp):\/\/(?:(?<user>[^@\s]+)@)?(?<host>[^\?\s\:]+)(?:\:(?<port>[0-9]+))?(?:\?(?<password>.+))?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}