import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\/content\\/usergenerated)(.*?)(?=\\/jcr\\:content)";
final String string = "{\n"
+ " \"path\":\"/content/usergenerated/content/webAppName/en/home/support/sample-guide/jcr:content/feedback/feedback3e41-\",\n"
+ " \"created\":\"2014-02-24 11:40:12\"\n"
+ "},\n"
+ "{\n"
+ " \"path\":\"/content/usergenerated/content/webAppName/en/home/support/governance-policy/jcr:content/feedback/feedback97b7-\",\n"
+ " \"created\":\"2014-03-21 09:08:04\"\n"
+ "},\n"
+ "{\n"
+ " \"path\":\"/content/usergenerated/content/webAppName/en/home/support/test-page-1/jcr:content/feedback/feedback827c-12345[2]\",\n"
+ " \"created\":\"2014-03-21 09:28:44\"\n"
+ "},\n"
+ "{\n"
+ " \"path\":\"/content/usergenerated/content/webAppName/en/home/shopping/fruit/bananas/jcr:content/feedback/feedbackfb13-\",\n"
+ " \"created\":\"2014-03-25 08:38:40\"\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}