use strict;
my $str = '{
"path":"/content/usergenerated/content/webAppName/en/home/support/sample-guide/jcr:content/feedback/feedback3e41-",
"created":"2014-02-24 11:40:12"
},
{
"path":"/content/usergenerated/content/webAppName/en/home/support/governance-policy/jcr:content/feedback/feedback97b7-",
"created":"2014-03-21 09:08:04"
},
{
"path":"/content/usergenerated/content/webAppName/en/home/support/test-page-1/jcr:content/feedback/feedback827c-12345[2]",
"created":"2014-03-21 09:28:44"
},
{
"path":"/content/usergenerated/content/webAppName/en/home/shopping/fruit/bananas/jcr:content/feedback/feedbackfb13-",
"created":"2014-03-25 08:38:40"
}';
my $regex = qr/(?:\/content\/usergenerated)(.*?)(?=\/jcr\:content)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}