import Foundation
let pattern = #"(?:\/content\/usergenerated)(.*?)(?=\/jcr\:content)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{
"path":"/content/usergenerated/content/webAppName/en/home/support/sample-guide/jcr:content/feedback/feedback3e41-",
"created":"2014-02-24 11:40:12"
},
{
"path":"/content/usergenerated/content/webAppName/en/home/support/governance-policy/jcr:content/feedback/feedback97b7-",
"created":"2014-03-21 09:08:04"
},
{
"path":"/content/usergenerated/content/webAppName/en/home/support/test-page-1/jcr:content/feedback/feedback827c-12345[2]",
"created":"2014-03-21 09:28:44"
},
{
"path":"/content/usergenerated/content/webAppName/en/home/shopping/fruit/bananas/jcr:content/feedback/feedbackfb13-",
"created":"2014-03-25 08:38:40"
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)