re = /(?:\/content\/usergenerated)(.*?)(?=\/jcr\:content)/
str = '{
"path":"/content/usergenerated/content/webAppName/en/home/support/sample-guide/jcr:content/feedback/feedback3e41-",
"created":"2014-02-24 11:40:12"
},
{
"path":"/content/usergenerated/content/webAppName/en/home/support/governance-policy/jcr:content/feedback/feedback97b7-",
"created":"2014-03-21 09:08:04"
},
{
"path":"/content/usergenerated/content/webAppName/en/home/support/test-page-1/jcr:content/feedback/feedback827c-12345[2]",
"created":"2014-03-21 09:28:44"
},
{
"path":"/content/usergenerated/content/webAppName/en/home/shopping/fruit/bananas/jcr:content/feedback/feedbackfb13-",
"created":"2014-03-25 08:38:40"
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end