const regex = /(([0-9]{4})(-[0-9]{2}){2}([^|]+\|){3})((.(?!\2))*
)/sg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([0-9]{4})(-[0-9]{2}){2}([^|]+\\|){3})((.(?!\\2))*
)', 'sg')
const str = `2015-03-03 19:30:47.2725|INFO|MyApp|Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Aenean commodo ligula eget dolor. Aenean massa. Cum sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus.
2015-03-03 19:31:29.1209|INFO|MyApp|Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Aenean commodo ligula eget dolor.
2015-03-03 19:32:50.1106|INFO|MyApp|Lorem ipsum dolor sit amet, consectetuer adipiscing elit.
2015-03-03 19:33:20.2683|ERROR|MyApp|Lorem ipsum dolor sit amet, consectetuer adipiscing elit. -> Aenean commodo ligula eget dolor. Aenean massa. -> Cum sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}