import Foundation
let pattern = #"""
(([0-9]{4})(-[0-9]{2}){2}([^|]+\|){3})((.(?!\2))*
)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
2015-03-03 19:30:47.2725|INFO|MyApp|Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Aenean commodo ligula eget dolor. Aenean massa. Cum sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus.
2015-03-03 19:31:29.1209|INFO|MyApp|Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Aenean commodo ligula eget dolor.
2015-03-03 19:32:50.1106|INFO|MyApp|Lorem ipsum dolor sit amet, consectetuer adipiscing elit.
2015-03-03 19:33:20.2683|ERROR|MyApp|Lorem ipsum dolor sit amet, consectetuer adipiscing elit. -> Aenean commodo ligula eget dolor. Aenean massa. -> Cum sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)