$re = '/(([0-9]{4})(-[0-9]{2}){2}([^|]+\|){3})((.(?!\2))*
)/s';
$str = '2015-03-03 19:30:47.2725|INFO|MyApp|Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Aenean commodo ligula eget dolor. Aenean massa. Cum sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus.
2015-03-03 19:31:29.1209|INFO|MyApp|Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Aenean commodo ligula eget dolor.
2015-03-03 19:32:50.1106|INFO|MyApp|Lorem ipsum dolor sit amet, consectetuer adipiscing elit.
2015-03-03 19:33:20.2683|ERROR|MyApp|Lorem ipsum dolor sit amet, consectetuer adipiscing elit. -> Aenean commodo ligula eget dolor. Aenean massa. -> Cum sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);