use strict;
my $str = '2015-03-03 19:30:47.2725|INFO|MyApp|Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Aenean commodo ligula eget dolor. Aenean massa. Cum sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus.
2015-03-03 19:31:29.1209|INFO|MyApp|Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Aenean commodo ligula eget dolor.
2015-03-03 19:32:50.1106|INFO|MyApp|Lorem ipsum dolor sit amet, consectetuer adipiscing elit.
2015-03-03 19:33:20.2683|ERROR|MyApp|Lorem ipsum dolor sit amet, consectetuer adipiscing elit. -> Aenean commodo ligula eget dolor. Aenean massa. -> Cum sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus.
';
my $regex = qr/(([0-9]{4})(-[0-9]{2}){2}([^|]+\|){3})((.(?!\2))*
)/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}