# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([a-z0-9\+]*)/'/gi;t' <<< "content/foo/B6128/8918/foo+bar+foo"