#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)([a-z0-9\+]*)"
Local $sString = "content/foo/B6128/8918/foo+bar+foo"
Local $sSubst = "'"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)