#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?<=\u0001).*?(?=\u0003)"
Local $sString = "{123}{345}{4" & @CRLF & _
"5" & @CRLF & _
"6" & @CRLF & _
"}{111}{222}{3" & @CRLF & _
"3" & @CRLF & _
"3" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")