import Foundation
let pattern = #"(?s)(?<=\u0001).*?(?=\u0003)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{123}{345}{4
5
6
}{111}{222}{3
3
3
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}