$re = '/(?s)(?<=\u0001).*?(?=\u0003)/';
$str = '{123}{345}{4
5
6
}{111}{222}{3
3
3
}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);