using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(?<=\u0001).*?(?=\u0003)";
string input = @"{123}{345}{4
5
6
}{111}{222}{3
3
3
}";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}