using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"substring1[^s]*(?:s(?!ubstring2)[^s]*)*substring2";
string input = @"ext Text Text Text Text Text Text Text substring1 Text Text Text Text Text Text Text substring2 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substg1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}