import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "substring1[^s]*(?:s(?!ubstring2)[^s]*)*substring2";
final String string = "ext Text Text Text Text Text Text Text substring1 Text Text Text Text Text Text Text substring2 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substg1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}