$re = '/substring1[^s]*(?:s(?!ubstring2)[^s]*)*substring2/';
$str = 'ext Text Text Text Text Text Text Text substring1 Text Text Text Text Text Text Text substring2 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substg1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);