const regex = /substring1[^s]*(?:s(?!ubstring2)[^s]*)*substring2/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('substring1[^s]*(?:s(?!ubstring2)[^s]*)*substring2', '')
const str = `ext Text Text Text Text Text Text Text substring1 Text Text Text Text Text Text Text substring2 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substg1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substri Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text ng1 Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text sub Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text substr Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text Text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}