use strict;
my $str = 'project_id=:pProjectId and NVL(START_DATE,:pStopTime) <= :pStopTime and NVL(COMPLETION_DATE,:pStartTime) >= :pStartTime and expenditure_org_id = :pBusinessUnit';
my $regex = qr`@(?)(?<parameter>\w+)`p;
my $subst = '';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";