import Foundation
let pattern = #"@(?)(?<parameter>\w+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"project_id=:pProjectId and NVL(START_DATE,:pStopTime) <= :pStopTime and NVL(COMPLETION_DATE,:pStartTime) >= :pStartTime and expenditure_org_id = :pBusinessUnit"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)