using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\b([A-Za-z]\s*){1,2}\s*(\d\s*){7})";
string input = @"PA 3 43 4 3 4 3
PA3434343Ausdfl98439439
a8923829293";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}