import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\b([A-Za-z]\\s*){1,2}\\s*(\\d\\s*){7})";
final String string = "PA 3 43 4 3 4 3\n\n"
+ "PA3434343Ausdfl98439439\n"
+ "a8923829293";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}