re = /^(\b([A-Za-z]\s*){1,2}\s*(\d\s*){7})/m
str = 'PA 3 43 4 3 4 3
PA3434343Ausdfl98439439
a8923829293'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end