using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"mongodb:\/\/(?:(?:[^:]+):(?:[^@]+)?@)?(?:(?:(?:[^\/]+)|(?:\/.+.sock?),?)+)(?:\/([^\/\.\ ""*<>:\|\?]*))?(?:\?(?:(.+=.+)&?)+)*";
string input = @"mongodb://app:user@db1.example.net,app:user@db2.example.net:2500/?replicaSet=test&connectTimeoutMS=300000";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}