import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "mongodb:\\/\\/(?:(?:[^:]+):(?:[^@]+)?@)?(?:(?:(?:[^\\/]+)|(?:\\/.+.sock?),?)+)(?:\\/([^\\/\\.\\ \"*<>:\\|\\?]*))?(?:\\?(?:(.+=.+)&?)+)*";
final String string = "mongodb://app:user@db1.example.net,app:user@db2.example.net:2500/?replicaSet=test&connectTimeoutMS=300000";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}