import re
regex = re.compile(r"mongodb:\/\/(?:(?:[^:]+):(?:[^@]+)?@)?(?:(?:(?:[^\/]+)|(?:\/.+.sock?),?)+)(?:\/([^\/\.\ \"*<>:\|\?]*))?(?:\?(?:(.+=.+)&?)+)*")
test_str = "mongodb://app:user@db1.example.net,app:user@db2.example.net:2500/?replicaSet=test&connectTimeoutMS=300000"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")