const regex = /mongodb:\/\/(?:(?:[^:]+):(?:[^@]+)?@)?(?:(?:(?:[^\/]+)|(?:\/.+.sock?),?)+)(?:\/([^\/\.\ "*<>:\|\?]*))?(?:\?(?:(.+=.+)&?)+)*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('mongodb:\\\/\\\/(?:(?:[^:]+):(?:[^@]+)?@)?(?:(?:(?:[^\\\/]+)|(?:\\\/.+.sock?),?)+)(?:\\\/([^\\\/\\.\\ "*<>:\\|\\?]*))?(?:\\?(?:(.+=.+)&?)+)*', '')
const str = `mongodb://app:user@db1.example.net,app:user@db2.example.net:2500/?replicaSet=test&connectTimeoutMS=300000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}