#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^.]*\.[^.]{2,3}(?:\.[^.]{2,3})?$"
Local $sString = "http://www.answers.com/article/1194427/8-habits-of-extraordinarily-likeable-people" & @CRLF & _
"http://www.apple.com" & @CRLF & _
"http://www.cnn.com.au" & @CRLF & _
"http://downloads.news.com.au" & @CRLF & _
"http://ftp.android.co.nz" & @CRLF & _
"http://global.news.ca" & @CRLF & _
"http://www.apple.com" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")