import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^.]*\\.[^.]{2,3}(?:\\.[^.]{2,3})?$";
final String string = "http://www.answers.com/article/1194427/8-habits-of-extraordinarily-likeable-people\n"
+ "http://www.apple.com\n"
+ "http://www.cnn.com.au\n"
+ "http://downloads.news.com.au\n"
+ "http://ftp.android.co.nz\n"
+ "http://global.news.ca\n"
+ "http://www.apple.com\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}