import re
regex = re.compile(r"[^.]*\.[^.]{2,3}(?:\.[^.]{2,3})?$", flags=re.MULTILINE)
test_str = ("http://www.answers.com/article/1194427/8-habits-of-extraordinarily-likeable-people\n"
"http://www.apple.com\n"
"http://www.cnn.com.au\n"
"http://downloads.news.com.au\n"
"http://ftp.android.co.nz\n"
"http://global.news.ca\n"
"http://www.apple.com\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")