re = /[^.]*\.[^.]{2,3}(?:\.[^.]{2,3})?$/m
str = 'http://www.answers.com/article/1194427/8-habits-of-extraordinarily-likeable-people
http://www.apple.com
http://www.cnn.com.au
http://downloads.news.com.au
http://ftp.android.co.nz
http://global.news.ca
http://www.apple.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end