using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<meta +name *=[\""']?description[\""']? *content=[\""']?(.*?)[\""']? */?>";
string input = @"<meta name=""description"" content=""Access Kenya is Kenya's leading corporate Internet service provider and is a technology solutions provider in Kenya with IT and network solutions for your business.Welcome to the Yellow Network.Kenya's leading Corporate and Residential ISP"" />
<meta name='description' content='Access Kenya is Kenya""s leading corporate Internet service provider and is a technology solutions provider in Kenya with IT and network solutions for your business.Welcome to the Yellow Network.Kenya's leading Corporate and Residential ISP' />
<meta name=description content=some content />";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}