package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<meta +name *=[\"']?description[\"']? *content=[\"']?(.*?)[\"']? */?>`)
var str = `<meta name="description" content="Access Kenya is Kenya's leading corporate Internet service provider and is a technology solutions provider in Kenya with IT and network solutions for your business.Welcome to the Yellow Network.Kenya's leading Corporate and Residential ISP" />
<meta name='description' content='Access Kenya is Kenya"s leading corporate Internet service provider and is a technology solutions provider in Kenya with IT and network solutions for your business.Welcome to the Yellow Network.Kenya's leading Corporate and Residential ISP' />
<meta name=description content=some content />`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}