$re = '~<meta +name *=[\"\']?description[\"\']? *content=[\"\']?(.*?)[\"\']? */?>~';
$str = '<meta name="description" content="Access Kenya is Kenya\'s leading corporate Internet service provider and is a technology solutions provider in Kenya with IT and network solutions for your business.Welcome to the Yellow Network.Kenya\'s leading Corporate and Residential ISP" />
<meta name=\'description\' content=\'Access Kenya is Kenya"s leading corporate Internet service provider and is a technology solutions provider in Kenya with IT and network solutions for your business.Welcome to the Yellow Network.Kenya\'s leading Corporate and Residential ISP\' />
<meta name=description content=some content />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);