use strict;
my $str = '<meta name="description" content="Access Kenya is Kenya\'s leading corporate Internet service provider and is a technology solutions provider in Kenya with IT and network solutions for your business.Welcome to the Yellow Network.Kenya\'s leading Corporate and Residential ISP" />
<meta name=\'description\' content=\'Access Kenya is Kenya"s leading corporate Internet service provider and is a technology solutions provider in Kenya with IT and network solutions for your business.Welcome to the Yellow Network.Kenya\'s leading Corporate and Residential ISP\' />
<meta name=description content=some content />';
my $regex = qr~<meta +name *=[\"']?description[\"']? *content=[\"']?(.*?)[\"']? */?>~p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}