#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "{% highlight %}([^{]*(?:{(?!% endhighlight %})[^{]*)*){% endhighlight %}"
Local $sString = "{% highlight %}" & @CRLF & _
"//some code" & @CRLF & _
"//some code" & @CRLF & _
"//some code" & @CRLF & _
"//some code" & @CRLF & _
"//some code" & @CRLF & _
"//some code" & @CRLF & _
"//some code" & @CRLF & _
"{% endhighlight %}" & @CRLF & _
"" & @CRLF & _
"{% highlight %}" & @CRLF & _
"//some code" & @CRLF & _
"//some code" & @CRLF & _
"//some code" & @CRLF & _
"//some code" & @CRLF & _
"//some code" & @CRLF & _
"{% endhighlight %}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")