$re = '/{% highlight %}([^{]*(?:{(?!% endhighlight %})[^{]*)*){% endhighlight %}/';
$str = '{% highlight %}
//some code
//some code
//some code
//some code
//some code
//some code
//some code
{% endhighlight %}
{% highlight %}
//some code
//some code
//some code
//some code
//some code
{% endhighlight %}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);