using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{% highlight %}([^{]*(?:{(?!% endhighlight %})[^{]*)*){% endhighlight %}";
string input = @"{% highlight %}
//some code
//some code
//some code
//some code
//some code
//some code
//some code
{% endhighlight %}
{% highlight %}
//some code
//some code
//some code
//some code
//some code
{% endhighlight %}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}