re = /{% highlight %}([^{]*(?:{(?!% endhighlight %})[^{]*)*){% endhighlight %}/
str = '{% highlight %}
//some code
//some code
//some code
//some code
//some code
//some code
//some code
{% endhighlight %}
{% highlight %}
//some code
//some code
//some code
//some code
//some code
{% endhighlight %}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end