#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.* (REV|LIB) .*).* COM .*$"
Local $sString = "0,5 MG COM CT BL AL/AL X 30" & @CRLF & _
"" & @CRLF & _
"0,4 MG COM REV CT BL AL AL X 90" & @CRLF & _
"" & @CRLF & _
"0,7 MG COM LIB PROL CT BL AL AL X 30 " & @CRLF & _
"" & @CRLF & _
"0,4 MG COM CT REV BL AL AL X 90" & @CRLF & _
"" & @CRLF & _
"0,4 MG COMERCIAL CT REVENDEDOR BL AL AL X 90" & @CRLF & _
"" & @CRLF & _
"0,4 MG REV COM CT BL AL AL X 90" & @CRLF & _
"" & @CRLF & _
"0,7 MG LIB PROL COM CT BL AL AL X 30 " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")