import re
regex = re.compile(r"^(?!.* (REV|LIB) .*).* COM .*$", flags=re.MULTILINE)
test_str = ("0,5 MG COM CT BL AL/AL X 30\n\n"
"0,4 MG COM REV CT BL AL AL X 90\n\n"
"0,7 MG COM LIB PROL CT BL AL AL X 30 \n\n"
"0,4 MG COM CT REV BL AL AL X 90\n\n"
"0,4 MG COMERCIAL CT REVENDEDOR BL AL AL X 90\n\n"
"0,4 MG REV COM CT BL AL AL X 90\n\n"
"0,7 MG LIB PROL COM CT BL AL AL X 30 \n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")