using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.* (REV|LIB) .*).* COM .*$";
string input = @"0,5 MG COM CT BL AL/AL X 30
0,4 MG COM REV CT BL AL AL X 90
0,7 MG COM LIB PROL CT BL AL AL X 30
0,4 MG COM CT REV BL AL AL X 90
0,4 MG COMERCIAL CT REVENDEDOR BL AL AL X 90
0,4 MG REV COM CT BL AL AL X 90
0,7 MG LIB PROL COM CT BL AL AL X 30
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}