#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\\newcommand)\{?([A-Za-z]*?)"
Local $sString = "\documentclass{article}" & @CRLF & _
"\newcommand\hello[1]{Hello, #1!}" & @CRLF & _
"\begin{document}" & @CRLF & _
"\hello{world} % says hello" & @CRLF & _
"\end{document}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")