$re = '/(\\\\newcommand)\{?([A-Za-z]*?)/';
$str = '\\documentclass{article}
\\newcommand\\hello[1]{Hello, #1!}
\\begin{document}
\\hello{world} % says hello
\\end{document}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);