using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\\newcommand)\{?([A-Za-z]*?)";
string input = @"\documentclass{article}
\newcommand\hello[1]{Hello, #1!}
\begin{document}
\hello{world} % says hello
\end{document}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}